The SAS® Deployment Backup and Recovery Tool displays an error with status code 693 when used with external or third-party databases


You might encounter an error that produces Status Code 693 when taking a backup using the SAS Deployment Backup and Recovery Tool or the SAS Backup Manager web application. This error occurs in environments where the SAS® Web Infrastructure Platform Data Server is hosted on an external or third-party database. Administrators are notified via email that the backup has encountered errors.

WARN and ERROR messages similar to the following might appear in the SASDeploymentBackup9.4.log file:

2022-04-17 04:00:01,128 [scheduler-1] WARN  [sasadm@saspw] com.sas.svcs.backup.dao.OMRContentServerSupportService - Backup of SAS Content Server will not be taken as it's on external database

2022-04-17 04:01:11,348 [scheduler-1] WARN  [sasadm@saspw] com.sas.svcs.backup.spi.BackupServiceImpl - Backup of SAS Content Server and Shared Services Database will not be taken as it is configured on external database.

2022-04-17 04:01:18,219 [scheduler-1] ERROR [sasadm@saspw] com.sas.svcs.backup.aop.ErrorLoggingAspect -     Error Start|||  <BackupErrors><BackupError><BackupErrorEntry><errorHeader><errorCode>693</errorCode><errorImpact>Not Available</errorImpact><errorClassification>Not Available</errorClassification><errorName>Not Available</errorName><errorCategory>Not Available</errorCategory><errorSummary>Not Available</errorSummary><dateTimeOfError>2022-04-17T04_01_11</dateTimeOfError><logName>SASDeploymentBackup9.4.log</logName><logFileLocation>/opt/sas/Config/Lev1/Web/Logs/SASServer1_1</logFileLocation><operationType>Not Available</operationType><errorOriginatingTier>demohost.sas.com</errorOriginatingTier></errorHeader><errorBody><errorMessage>Exception occured</errorMessage><stackTrace><![CDATA[Backup of SAS Content Server and Shared Services Database will not be taken as it is configured on external database.]]></stackTrace><possibleCause>Not Available</possibleCause><originalMessage>Not Available</originalMessage><remedyMessage>Not Available</remedyMessage></errorBody></BackupErrorEntry><errorNotificationInformation><isUserNotified>false</isUserNotified><mailDetails><mailSubject>Not Available</mailSubject><mailToAddress>Not Available</mailToAddress><mailCCAddress>Not Available</mailCCAddress></mailDetails></errorNotificationInformation></BackupError></BackupErrors>        |||  Error End

An exception notification similar to the following might appear in SAS Backup Manager if the backup was started from this application:

Status code

Additionally, administrators might receive an email notification about the error, which contains a message similar to the following:

Got Exception as follows:

 Backup Errors
         Error Entry:
                 Status Code: 693
                 Date and Time Of Error: 2022-06-12T18_04_22
                 Log Name: SASDeploymentBackup9.4.log
                 Log File Location: /opt/sas/Config/Lev1/Web/Logs/SASServer1_1
                 Originating Tier: demohost.sas.com
                 Message: Exception occured
                 Stack Trace: Backup of SAS Content Server and Shared Services Database will not be taken as it is configured on external database.

Cause

The inability to back up external and third-party databases is expected behavior.

The SAS Deployment Backup and Recovery Tool cannot instruct external or third-party databases to produce a backup package compatible with the Tool. This compatibility error causes the SAS® Content Server and database components of the backup to fail completion. The SAS Deployment Backup and Recovery Tool still attempts to back up the other components of the backup such as the SAS® Metadata Server and a subset of files under the SAS configuration directory.

This behavior is classified as an error message because a backup from the SAS Deployment Backup and Recovery Tool, which does not contain synchronized database and SAS Content Server components, might result in data loss if used in a recovery event. Using a backup methodology that does not depend on the SAS Deployment Backup and Recovery Tool is recommended in deployments where external or third-party databases are in use.

SAS Technical Support suggests that customers review the contents of the SAS Disaster Recovery Policy for guidance on backup methodologies to ensure data across deployment components is fully backed up and remains properly synchronized.


Workaround

The error message that is produced when the SAS Deployment Backup and Recovery Tool encounters external or third-party databases cannot be disabled.

If you acknowledge the risk of data loss from this scenario with the SAS Deployment Backup and Recovery Tool, this error can be ignored. If you do not want to see this error each time the SAS Deployment Backup and Recovery Tool takes a backup, SAS Technical Support provides assistance through the following actions:

For more guidance about the behavior around external and third-party databases, as well as details about the SAS Deployment Backup and Recovery Tool, refer to Chapter 11 of the SAS® 9.4 Intelligence Platform: System Administration Guide.